[Anthy-dev 970] Re: uim 0.4.1 released

Back to archive index

TOKUNAGA Hiroyuki tkng****@xem*****
2004年 7月 27日 (火) 17:53:13 JST


On Thu, 15 Jul 2004 14:01:23 +0900
Masanari Yamamoto <h0131****@ice*****> wrote:

> On Thu, Jul 15, 2004 at 02:04:48AM +0900, Konosuke Watanabe wrote:
> > 毎度変な要望で申し訳ないのですが,次のバージョンのuimに,
> > uim-fepのビルドの有無を設定するconfigureのオプションを追加し
> > て頂けないでしょうか.
> > 
> > 後輩が0.3.9と同じようにやってもSolaris8に全然入らないと苦し
> > んでいたので,見てみたらuim-fepのところでヘッダ類のincludeが
> > うまくいってないくて引っかかってました.エラーが出た箇所を片っ
> > 端から書き換えてコンパイルは何とか通るようになったんですが,
> > cfmakerawやforkptyが見当たらず,リンクできず撃沈しました.
> > 
> > 結局,「よく考えたらfepは使わないっす」「それもそうだな」と
> > いうことで,手でuim-fepを外してビルドしてインストールしたん
> > ですが,できればもう少しスマートに済ませたいと思いまし
> > て・・・.
> そうなんです。Solarisではuim-fepをコンパイルできません。
> Linuxでもlib(n)cursesがいるようなので、configureにuim-fep
> をインストールしないオプションを付けた方がいいと思います。

 もうSolarisでもコンパイルできるので不要なような気もするのですが、
--disable-fep オプションを付けました。

-- 
徳永拓之
tkng****@xem*****
http://kodou.net/



Anthy-dev メーリングリストの案内
Back to archive index