Incidencia #43598

CI: Update ubuntu runner to 22.04

Abrir Fecha: 2022-01-11 19:25 Última actualización: 2022-05-31 22:04

Informador:
Propietario:
Tipo:
Estado:
Cerrado
Componente:
Hito:
Prioridad:
5 - Medium
Gravedad:
5 - Medium
Resolución:
Fixed
Fichero:
1

Details

Opening the ticket a bit early to have it to link to -> this might be a dependency for #43362 (there's also other ways to resolve the issue blocking it)

Update github ubuntu builds to use 22.04 runner, once it becomes available.

Ticket History (3/9 Histories)

2022-01-11 19:25 Updated by: cazfi
  • New Ticket "CI: Update ubuntu runner to 22.04" created
2022-02-06 02:44 Updated by: cazfi
Comentario
2022-05-12 07:11 Updated by: cazfi
Comentario

Reply To cazfi

Github's supported runners are listed at https://docs.github.com/en/actions/using-github-hosted-runners/about-github-hosted-runners

There's ubuntu22.04 runner in public beta now.

2022-05-12 11:17 Updated by: cazfi
Comentario

With no qt5-default to install at all in ubuntu-22.04, this depends on #44561

2022-05-16 09:04 Updated by: cazfi
  • Propietario Update from (Ninguno) to cazfi
  • Resolución Update from Ninguno to Accepted
  • Hito Update from (Ninguno) to 3.1.0
2022-05-24 13:29 Updated by: cazfi
Comentario

Currently meson CI build fails, as it 1) does not define qtver to use -> defaults to Q6, and 2) ubuntu-20.04 runner has no Qt6 environment.

Instead of making the emergency fix of defining qtver=qt5, I'll test if the current patch here, to update runner to 22.04, resolves the issue.

2022-05-25 11:41 Updated by: cazfi
Comentario

Reply To cazfi

Currently meson CI build fails

-> #44661

2022-05-31 22:04 Updated by: cazfi
  • Estado Update from Open to Cerrado
  • Resolución Update from Accepted to Fixed

Editar

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Entrar