Incidencia #44513

qt6.m4 sets QT_DISABLE_DEPRECATED_BEFORE below Qt6

Abrir Fecha: 2022-05-05 14:56 Última actualización: 2022-05-28 17:32

Informador:
Propietario:
(Ninguno)
Tipo:
Estado:
Open
Componente:
Hito:
Prioridad:
5 - Medium
Gravedad:
5 - Medium
Resolución:
Ninguno
Fichero:
Ninguno

Details

For Qt6 compilation QT_DISABLE_DEPRECATED_BEFORE should obviously be at least 6.0. qt6.m4 currently sets it to 0x050f00

Ticket History (2/2 Histories)

2022-05-05 14:56 Updated by: cazfi
  • New Ticket "qt6.m4 sets QT_DISABLE_DEPRECATED_BEFORE below Qt6" created
2022-05-28 17:32 Updated by: cazfi
Comentario

Qt6 still seems to support some things deprecated in 6.0.0 -> we can't simply bump the QT_DISABLE_DEPRECATED_BEFORE without some code changes.

We probably don't want to start making those changes to S3_1.

Attachment File List

No attachments

Editar

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Entrar