• R/O
  • HTTP
  • SSH
  • HTTPS

lfsja-git: Commit

lfsja-git


Commit MetaInfo

Revisióna9eb9e3b76b72804376d71a9e1ca70c54f447c70 (tree)
Tiempo2021-05-14 07:21:30
Autormatsuand <30614168+matsuand@user...>
Commitermatsuand

Log Message

[lfsja-git] r10.1-63 対応。

Cambiar Resumen

Diferencia incremental

--- a/configure
+++ b/configure
@@ -4720,7 +4720,7 @@ fi
47204720
47214721
47224722
4723-TARGETVER=r10.1-61
4723+TARGETVER=r10.1-63
47244724
47254725 (cd ${bookdir} && sh git-version.sh)
47264726 if test -f ${bookdir}/version.ent; then
--- a/src/chapter01/jchangelog.ch
+++ b/src/chapter01/jchangelog.ch
@@ -56,6 +56,17 @@
5656 -->
5757
5858 <listitem>
59+ <para>2021-05-14</para>
60+ <itemizedlist>
61+ <listitem>
62+ <para>[matsuand] -
63+ r10.1-63 (<ulink url="&lfs-changeset;8725caed0">8725caed0</ulink>) までの対応。
64+ </para>
65+ </listitem>
66+ </itemizedlist>
67+ </listitem>
68+
69+ <listitem>
5970 <para>2021-05-12</para>
6071 <itemizedlist>
6172 <listitem>
--- a/src/chapter05/glibc.ch
+++ b/src/chapter05/glibc.ch
@@ -222,6 +222,15 @@
222222 @z
223223
224224 @x
225+ <para>Fix hardcoded path to the executable loader in
226+ <command>ldd</command> script:</para>
227+@y
228+ <para>
229+ <command>ldd</command> スクリプト内にある実行可能なローダーへのパスがハードコーディングされているので、これを修正します。
230+ </para>
231+@z
232+
233+@x
225234 <para>At this point, it is imperative to stop and ensure that the basic
226235 functions (compiling and linking) of the new toolchain are working as
227236 expected. To perform a sanity check, run the following commands:</para>
--- a/src/chapter08/glibc.ch
+++ b/src/chapter08/glibc.ch
@@ -243,26 +243,6 @@
243243 </para>
244244 @z
245245
246-%@x
247-% <para>The
248-% <emphasis>nptl/tst-thread-affinity-{pthread,pthread2,sched}</emphasis>
249-% tests may fail for reasons that have not been determined. </para>
250-%@y
251-% <para>
252-% <emphasis>nptl/tst-thread-affinity-{pthread,pthread2,sched}</emphasis> テストは失敗しますが、その理由は不明です。
253-% </para>
254-%@z
255-
256-%@x
257-% <para>Other tests known to fail on some architectures are
258-% malloc/tst-malloc-usable and nptl/tst-cleanupx4. </para>
259-%@y
260-% <para>
261-% 上記以外に特定のアーキテクチャーにてテストが失敗することが分かっています。
262-% 失敗するのは malloc/tst-malloc-usable, nptl/tst-cleanupx4 です。
263-% </para>
264-%@z
265-
266246 @x
267247 <para>Though it is a harmless message, the install stage of Glibc will
268248 complain about the absence of <filename>/etc/ld.so.conf</filename>.
@@ -292,6 +272,15 @@
292272 @z
293273
294274 @x
275+ <para>Fix hardcoded path to the executable loader in
276+ <command>ldd</command> script:</para>
277+@y
278+ <para>
279+ <command>ldd</command> スクリプト内にある実行可能なローダーへのパスがハードコーディングされているので、これを修正します。
280+ </para>
281+@z
282+
283+@x
295284 <para>Install the configuration file and runtime directory for
296285 <command>nscd</command>:</para>
297286 @y
--- a/src/general.ch
+++ b/src/general.ch
@@ -24,9 +24,9 @@
2424 <!ENTITY releasedate "August 26th, 2021">
2525 <!ENTITY copyrightdate "1999-2021">
2626 -->
27-<!ENTITY jversion "20210513">
28-<!ENTITY jversiond "20210513">
29-<!ENTITY jcorrespondSHA "5d0219fda"> <!-- lfs-git SHA 値; 本箇所での記載のみ -->
27+<!ENTITY jversion "20210514">
28+<!ENTITY jversiond "20210514">
29+<!ENTITY jcorrespondSHA "8725caed0"> <!-- lfs-git SHA 値; 本箇所での記載のみ -->
3030 <!ENTITY dir-jversion "git-ja">
3131 <!ENTITY dir-jversiond "git-sysdja">
3232 @z
--- a/version.ac
+++ b/version.ac
@@ -2,5 +2,5 @@ dnl
22 dnl This is part of LFSbookja package.
33 dnl
44 dnl m4-include this file to define the current LFS version
5-m4_define([lfs_version], [r10.1-61])
6-m4_define([lfsd_version], [r10.1-61-systemd])
5+m4_define([lfs_version], [r10.1-63])
6+m4_define([lfsd_version], [r10.1-63-systemd])
Show on old repository browser