Foros: OpenMIDIProject forum (Thread #44996)

kawai ca99 (2022-01-10 22:53 by ta99 #88504)

Hi,

I am trying to use the internal soundbank of my digital piano, kawai ca99, which i cannot find the *.ins file online.
using MIDITester, i was able to access the digital piano's internal bank sound entering the MSB, LSB, and program name alone use 'NAIVE' mode.
however I could't not do so in sekaiju. Can anybody help me out please?

Responder al #88504×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Entrar

Re: kawai ca99 (2022-01-11 07:54 by kuzu #88505)

Thank you for using Sekaiju.

If you don't have ins file, to enter arbitrary MSB, LSB, or program number, please input by the numpad key.
Or, uncheck "Setup" - "Options..." - "Search only available tone when CC#0, CC#32, or program number is up or downed."
Responder al #88504

Responder al #88505×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Entrar

Re: kawai ca99 (2022-01-11 09:34 by ta99 #88506)

Reply To Message #88505
> Thank you for using Sekaiju.
>
> If you don't have ins file, to enter arbitrary MSB, LSB, or program number, please input by the numpad key.
> Or, uncheck "Setup" - "Options..." - "Search only available tone when CC#0, CC#32, or program number is up or downed."

Hi,

I have tried doing that. In MIDITester, I could get this to work, and if I make a program change on my keyboard the change would reflect on MIDITester
But in Sekaiju, it could only access the General Midi sound on MSB 0, but not sound on MSB 95, 121. Only MSB 95, 121 it produces a sound, but it does not change sound when i change the program number.
Responder al #88505

Responder al #88506×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Entrar

Re: kawai ca99 (2022-01-11 12:39 by kuzu #88510)

Here shows some hints.

Sekaiju -> kawai ca99

CC#0 Bank Select MSB = x
CC#32 Bank Select LSB = y
Program number = z

The MIDI message must be sent in this order.
Please check in the event list window carefully.
and then playback the the sequence.

In your piano, if GM or some mode, MSB and LSB will be ignored. Please use native mode.
To set native mode forcibly, please send GM system off's sysex message.

kawai ca99 -> Sekaiju

1.Push real time record button.
2.Send program change from ca99 to Sekaiju.
3.Stop real time record button.
4.In the event list window, check the inputed message.
The track list window's MSB, LSB and Program Number indicates only the first one in the track.
The second or later changes must be check in the event list window.

Responder al #88505

Responder al #88510×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Entrar

Re: kawai ca99 (2022-01-11 16:15 by ta99 #88511)

Hi, thank you very much for your help.
For the most part I got it to work.

I am following this guide below to select my instruments.
https://www.kawai-global.com/data/manuals/cax9/CA99_CA79_MIDI_Settings_Manual_EN_R100.pdf
All the MIDI sound works as expected. However, for the on board sound, I found out that the program number for the onboard sound is always off by 1 (i.e. If I want to select SK-EX Rendering it should be Program Number 0, MSB 95 LSB 112, instead of Program Number being 1 as stated on the guide).

Sometimes I am able to to change the instrument just by typing in the number and the sound will immediately reflect the change
othertimes I have to restart the playback of the sequence in order for the sound to 'update'
Responder al #88510

Responder al #88511×

You can not use Wiki syntax
You are not logged in. To discriminate your posts from the rest, you need to pick a nickname. (The uniqueness of nickname is not reserved. It is possible that someone else could use the exactly same nickname. If you want assurance of your identity, you are recommended to login before posting.) Entrar